Canon Pixma 4000 R weigert sich zu Drucken

Drucken über das Netzwerk
Antworten
skytor
Beiträge: 3
Registriert: Sa 07 Okt, 2006 08:43

Canon Pixma 4000 R weigert sich zu Drucken

Beitrag von skytor » Sa 07 Okt, 2006 09:00

Hallo Linux Gemeinde

habe da ein kleines Problem mit meinem Canon Pixma4000R unter Suse 10.1 (Linux 2.6.16.21-0.25-default x86_64) mit KDE 3.5.1

habe wegen eines defektes der Festplatte das System neu erstellen müssen .. bei der neuinstallation wurde das gleiche Medium verwendet wie bei der erst Installation .. ebendso alle Online Updates

Problem .. VOR der Neuinstallation lief mein Canon mit CUPS eingeschränkt (Seiten wurden zu klein gedruckt) und mit TurboPrint ging alles 1A .... nach der Neuinstallation wehrt sich der Drucker mit Händen und Füssen ... mit CUPS das alte Spiel .. seiten werden in ca 25% Grösse gedruckt ... nur unter Turboprint tut sich garnix mehr ... er sagt zwar immer die Jobs wurden abgearbeitet aber am Drucker regt sich aber garnix .... Start Stop funktioniert (wechsel rot/grün) hat einer mal ne funktionierende besispielconfig für mich ?
IP des Druckers 192.168.0.4 Socket 9100 (diese daten nutze ich auch unter CUPS wo er dann zu klein druckt)

im truboprint log taucht immer auf

-r must be followed by <res> or <xres> x <yres>

kommt mir so vor als wüste er nich wie gross er die seite drucken soll .... blos mehr als DINA4 und Color und 300dpi anklicken kann ich ja nu mal nicht :-(

zedonet
Administrator
Beiträge: 1474
Registriert: Fr 29 Sep, 2006 13:10

Beitrag von zedonet » Mo 09 Okt, 2006 08:51

Ein kompletter Abschnitt im turboprint_cups.log für einen Druckauftrag wäre zur Fehleranalyse hilfreich.

Folgende Problemursachen sind vorstellbar:

- Problem mit Zugriffsrechten - die Verzeichnisse /usr/share/turboprint und Unterverzeichnisse sind nur für root und nicht für Anwender lesbar. Evtl. läßt sich das "von Hand" beheben:

chmod go+r /usr/share/turboprint
chmod go+r /usr/share/turboprint/*
chmod go+r /usr/share/turboprint/*/*

- die PPD-Datei für den TurboPrint-Drucker in /etc/cups/ppd wurde nicht korrekt geschrieben. Lösung: Drucker über TurboPrint Setup / Kommandozeile "xtpsetup" entfernen und neu einrichten.

Antworten