Canon MG7550 issue

Drucken über das Netzwerk
Antworten
claessek
Beiträge: 3
Registriert: So 17 Jan, 2016 21:20

Canon MG7550 issue

Beitrag von claessek » So 17 Jan, 2016 21:50

Hello,
I'm running linux RHEL 7.2 with CUPS 1.6 on a laptop provided by my employer.
At home I have a canon PIXMA MG7550.
I installed the driver from the canon website: cnijfilter2-5.00-1-rpm.tar.gz
Installation went fine and I could define the device in CUPS but it wouldn't print.
Through a support forum I was directed to Turboprint.
I installed the test version and I am willing to buy the license if it works.

I configured the MG7550 and I was able to request the ink levels and print a test page.

However after a very short time the monitor shows: "no connection to the turboprint daemon"
Then I restart the daemon: service tpdaemon restart (as root)
Output:
tprintdaemon: no process found
TP-Daemon Version 2.38-1
Debug Level set to 0
TurboPrint daemon restarted

The "no process found" part seems strange????

After restarting I can use TP for a minute or so and then the connection drops again.
Could this be some timeout???
Any hints on how to avoid this?

Contents of turboprint.cfg:

[Turboprint_Config_File]

[turbo6]
Default=0
Name="Canon_PIXMA_MG7500series_(TurboPrint)"
Short="MG7500series-TurboPrint"
Port="uri"
Devicename="/dev/lp0"
Filename="/tmp/turboprint.prn"
Remoteprinter=""
Remoteserver=""
Remoteuser=""
Remotepassword=""
Remoteworkgroup=""
Remoteip=""
Remotesocket=""
Remoteuri="bjnp://192.168.0.20"
Driver="Canon_PIXMA_MG7500series"
Redirectqueue=""
Redirectmonitor=""
Colormode=2
Preview=1
Cartridge=0
Paper=0
Quality=1
Pagesize=3
Borderlessexpand=2
Customsize=5000,7000
Feed=0
Tray=0
Duplex=0,0,0
Copies=1
Dithering=0
Truematch=1
Mirror=0
Usercolor=0
Brightness=0
Contrast=0
Screengamma=180
Inkvolume=0
Shadows=0
Colorsaturation=0
Intensity_KCMY=0,0,0,0
Limit_KCMY=0,0,0,0
Inklimit=0
Bright_KCMY=0,0,0,0
UCR=0
TAC=0
Colorspace=0
CMYKspace=0
Intent=1
Greytone_AB=0,0
RefLight=6500
GS_X_Scale=100
GS_Y_Scale=100
GS_X_Offset=0
GS_Y_Offset=0
GS_Screen_Lpi=0
GS_Buffer=0
PIC_Ignore_Margins=0
PIC_Position=0,0
PIC_Size=7000,0
PIC_Center=1,1
PIC_Aspect=1
A2PS_Defaults=0
A2PS_Landscape=0
A2PS_Borders=1
A2PS_Headers=1
A2PS_Columns=1
Landscape=0
Number_Up=1
Image_X=1
Image_Y=1
Image_Scaling=100
Use_Image_Scaling=0
Image_DPI=300
Use_Image_DPI=0
Text_CPI=10
Text_LPI=6
Pretty_Print=0
Settings=0,0,0,0,0,0,0,0,0,0


Contents of system.cfg:

TP_CUPS=1
TP_UNIT=1
TP_LANGUAGE=en
TP_CHARSET=UTF-8
TP_INSTALLATIONSTATE=0
TPBIN_BROWSER=firefox
TPFILE_PRINTCAP=/etc/printcap
TPPATH_CONFIG=/etc/turboprint
TPPATH_SHARE=/usr/share/turboprint
TPPATH_SPOOL=/var/spool/lpd
TPPATH_BIN=/usr/bin
TPPATH_FILTERS=/usr/lib/turboprint
TPPATH_DOC=/usr/share/turboprint/doc
TPPATH_LOG=/var/log
TPPATH_VAR=/var/spool
TPPATH_TEMP=/tmp
TPPATH_MAN=/usr/share/man
TPPATH_CUPSDRIVER=/usr/share/cups/model
TPPATH_CUPSSETTINGS=/etc/cups/ppd
TPPATH_CUPSLIB=/usr/lib/cups
TPPATH_CUPSLIB64=/usr/lib64/cups
TPOWN_SPOOLDIR=lp
TPMOD_SPOOLDIR=0755
TPOWN_SPOOLFILE=lp
TPMOD_SPOOLFILE=0640
TPDAEMON_START=1
TPDAEMON_USER=lp
TPDAEMON_GROUP=lp
TPDAEMON_PORT=5552
TPDAEMON_SERVER=1
TPUSE_GSZEDO=1

zedonet
Administrator
Beiträge: 1473
Registriert: Fr 29 Sep, 2006 13:10

Re: Canon MG7550 issue

Beitrag von zedonet » Mo 18 Jan, 2016 10:59

Hello,

the TurboPrint daemon is a component that provides ink status monitoring while the printer is not printing. It is not necessary for printing, only for displaying ink status.

There is a problem with turboprint daemon terminating with network / WiFi connected printers, there is no problem with USB connection.

We are working on this problem and will provide a fix.

claessek
Beiträge: 3
Registriert: So 17 Jan, 2016 21:20

Re: Canon MG7550 issue

Beitrag von claessek » Mo 18 Jan, 2016 11:09

Thanks you for the feedback.
I can confirm however that at the time I receive the error printing does not work either. The printout is accepted but disappears somewhere.
I noticed that the deamon remains active and when TP monitor is started a 2nd deamon with the same name becomes active also (with a different PID).
Do you have a view on a possible fix? I can not decide on buying the product if a solution won't be available on short notice..

thanks for your help,

zedonet
Administrator
Beiträge: 1473
Registriert: Fr 29 Sep, 2006 13:10

Re: Canon MG7550 issue

Beitrag von zedonet » Mo 18 Jan, 2016 11:41

If the IP address is correct (192.168.0.20), printing should work fine. You could check if the terminal command

ping 192.168.0.20

shows that the printer can be reached through the network.

Of course you can also try to print via USB connection.

claessek
Beiträge: 3
Registriert: So 17 Jan, 2016 21:20

Re: Canon MG7550 issue

Beitrag von claessek » Mo 18 Jan, 2016 11:48

Hello,
IP-address is ok.
printing from Windows laptops is ok.
USB is not suiteble since the printer is used by 3 other laptops.
Would an ethernet connection make a difference or is it network connectivity in general that is the problem?

Antworten