Problem beim einrichten des Printservers DPR-1020 von DLink

Drucken über das Netzwerk
Antworten
Martin
Beiträge: 1
Registriert: So 07 Mär, 2010 21:24

Problem beim einrichten des Printservers DPR-1020 von DLink

Beitrag von Martin » So 07 Mär, 2010 22:35

Hallo,

vielleicht kann mir jemand helfen, ich habe folgende Konfiguration:
Drucker: Canon Pixma IP4200
Printserver: DLink DPR-1020
Router: DLink DI-524
Software: SUSE 11.1
der Druckserver hat eine statische IP-Adresse, der zweite HTTP-Port ist freigeschaltet zum drucken über ipp (Port 631). Den Drucker mit Turboprint (V2.13-2) als Netzwerkdrucker (ipp) installiert. Das drucken funktioniert auch ohne Probleme, aber ich bekomme keine Anzeige über den Tintenstand.
Im Turboprint Monitor bekomme ich die Statusanzeige: keine Verbindung zum Remote-Dämon
Ich habe auch schon versucht über YAST den Printserver einzurichten, jedoch mit dem gleichen Ergebnis.
(Als lokaler Drucker (USB-Schnittstelle) eingerichtet, funktioniert alles).
Hier das Listung der Datei turboprint.cfg:
[Turboprint_Config_File]

[turbo1]
Default=0
Name="Canon_PIXMA_iP4200"
Short="tpu"
Port="ipp"
Devicename="/dev/lp0"
Filename="/tmp/turboprint.prn"
Remoteprinter="dlk-9D2D7E-U1"
Remoteserver="192.168.0.99"
Remoteuser=""
Remotepassword=""
Remoteworkgroup=""
Remoteip=""
Remotesocket=""
Remoteuri=""
Driver="Canon_PIXMA_iP4200"

das Listing der Datei system.cfg:
TP_CUPS=1
TP_UNIT=0
TP_LANGUAGE=de
TP_CHARSET=de_DE
TP_INSTALLATIONSTATE=0
TPBIN_BROWSER=firefox
TPFILE_PRINTCAP=/etc/printcap
TPPATH_CONFIG=/etc/turboprint
TPPATH_SHARE=/usr/share/turboprint
TPPATH_SPOOL=/var/spool/lpd
TPPATH_BIN=/usr/bin
TPPATH_FILTERS=/usr/share/turboprint/lib
TPPATH_DOC=/usr/share/turboprint/doc
TPPATH_LOG=/var/log
TPPATH_VAR=/var
TPPATH_TEMP=/tmp
TPPATH_MAN=/usr/share/man
TPPATH_CUPSDRIVER=/usr/share/cups/model
TPPATH_CUPSSETTINGS=/etc/cups/ppd
TPPATH_CUPSLIB=/usr/lib/cups
TPPATH_CUPSLIB64=
TPOWN_SPOOLDIR=lp
TPMOD_SPOOLDIR=0755
TPOWN_SPOOLFILE=lp
TPMOD_SPOOLFILE=0640
TPDAEMON_START=1
TPDAEMON_USER=lp
TPDAEMON_GROUP=lp
TPDAEMON_PORT=5552
TPDAEMON_SERVER=1

zedonet
Administrator
Beiträge: 1473
Registriert: Fr 29 Sep, 2006 13:10

Beitrag von zedonet » Mo 08 Mär, 2010 11:42

Hallo,

die Statusanzeige funktioniert beim Netzwerkdruck nur in bestimmten Fällen, wo eine bidirektionale Kommunikation mit dem Drucker sichergestellt werden kann:

1. Canon-Drucker mit eingebauter Netzwerkschnittstelle

2. Drucker ist über USB an einen Linux-Server angeschlossen, auf dem TurboPrint installiert ist - dann ist auch auf Linux Clients der Tintenstand sichtbar

In Verbindung mit dem DLink-Router kann nur eine unidirektionale Verbindung zum Drucker hergestellt werden (Senden von Druckdaten möglich, jedoch keine Statusabfrage).

Antworten