Ubuntu 14.04 LTS - Cups Error

Fragen zu bestimmten Linux-Distributionen
Antworten
Studentenfutter
Beiträge: 6
Registriert: Di 15 Jul, 2014 07:03

Ubuntu 14.04 LTS - Cups Error

Beitrag von Studentenfutter » Di 15 Jul, 2014 07:15

Hallo Turboprinter.

Ich habe seit ein paar Tagen unter Ubuntu 14.04 LTS 64-bit folgendes Problem:

Nach dem Rechnerstart bekomme ich vom Turboprint-Monitor die Meldung:

Turboprint-Monitor Error: Cups is not running.

------------

Aber Cups ist installiert und ich habe in der letzten Zeit keine Änderungen vorgenommen.
Es fiel mir nur auf, dass ich keine Druckvorschau mehr bekomme.

Also gestern die neueste Turboprint-Version gezogen und installiert. .... Alles wunderbar.

Aber heute morgen das selbe wieder.: Turboprint-Monitor-Error: Cups is not running.

In der Paketverwaltung nachgeschaut und CUPS ist installiert und sollte laufen.


Kann mir jemand helfen??

Vielen Dank bis hierher.

Thomas

zedonet
Administrator
Beiträge: 1506
Registriert: Fr 29 Sep, 2006 13:10

Re: Ubuntu 14.04 LTS - Cups Error

Beitrag von zedonet » Di 15 Jul, 2014 08:53

Hallo,

ob CUPS im Moment läuft oder nicht, können Sie prüfen, indem Sie ein "Terminal"-Fenster öffnen und dort den Befehl

sudo service cups status

eintippen (Ihr Login-Passwort wird abgefragt). Sie erhalten als Ergebnis entweder "cups start/running" oder "cups stop/waiting".

Falls der Zustand "stop/waiting" ist, können Sie evtl. in der Logdatei /var/log/cups/error_log eine Fehlermeldung finden.

Mit

sudo service cups start

können Sie CUPS manuell starten.

Studentenfutter
Beiträge: 6
Registriert: Di 15 Jul, 2014 07:03

Re: Ubuntu 14.04 LTS - Cups Error

Beitrag von Studentenfutter » Di 15 Jul, 2014 09:42

Hallo zedonet,

die Abfrage im Terminal ergibt das CUPS läuft und auch eine Prozessnummer da ist.

Also den Turboprint-Monitor nochmal angeschubst .... keine reaktion! Das TP-Controlcenter hingegen startet wie gewohnt.

Dann einen Druckbefehl abgeschickt: ... keine Vorschau, sondern der Drucker legt sofort los.

Irgendwie läuft TP wohl nicht!

Bin im Moment ziemlich ratlos! ^^

zedonet
Administrator
Beiträge: 1506
Registriert: Fr 29 Sep, 2006 13:10

Re: Ubuntu 14.04 LTS - Cups Error

Beitrag von zedonet » Do 17 Jul, 2014 08:48

Sie können einmal versuchen, TurboPrint-Monitor neu zu starten:

killall turboprint-monitor
turboprint-monitor &

Klappt es dann?

Studentenfutter
Beiträge: 6
Registriert: Di 15 Jul, 2014 07:03

Re: Ubuntu 14.04 LTS - Cups Error

Beitrag von Studentenfutter » Fr 18 Jul, 2014 17:32

.... die Antwort im Terminal auf: killall turboprint-monitor

thomas@Linux-PC:~$ killall turboprint-monitor
turboprint-monitor: Kein Prozess gefunden
thomas@Linux-PC:~$ turboprint-monitor &
[1] 3636

... und jetzt ist der TP-Monitor angesprungen.

Muss dass jetzt als skript in autostart? :?:

zedonet
Administrator
Beiträge: 1506
Registriert: Fr 29 Sep, 2006 13:10

Re: Ubuntu 14.04 LTS - Cups Error

Beitrag von zedonet » Mo 21 Jul, 2014 11:06

Das Skript sollte schon im Autostart sein: die Datei

.config/autostart/turboprint-monitor.desktop

im home-Verzeichnis ruft

/usr/lib/turboprint/turboprint-startmonitor

und dort findet sich

turboprint-monitor 0 -hide &

(TurboPrint Monitor laden, Fenster noch nicht geöffnet).

Studentenfutter
Beiträge: 6
Registriert: Di 15 Jul, 2014 07:03

Re: Ubuntu 14.04 LTS - Cups Error

Beitrag von Studentenfutter » Di 22 Jul, 2014 17:30

Und noch die aktuelle Statusmeldung:

Einmalig das skript aufgerufen und seitdem klappt wieder alles. Auch beim nächsten und übernächsten Start.

Vielen Dank.

... so geht Support :-)

Antworten