Druck-Konfig, Daemon funktionieren nicht mehr

Fragen zur Installation
Antworten
tux666
Beiträge: 2
Registriert: Sa 22 Aug, 2015 07:41

Druck-Konfig, Daemon funktionieren nicht mehr

Beitrag von tux666 » Sa 22 Aug, 2015 08:21

Hallo,
ich habe gestern auf meinem Gentoo-Linux (64-bit) mit Hilfe des setup-Skripts Turboprint erfolgreich installieren und auch meinen Drucker Canon IP 4200 erfolgreich an der USB-Schnittstelle einrichten können (30-Tage-Trail-Version, noch nicht freigeschaltet).
Mit diesem Drucker will ich hauptsächlich CDs und DVDs bedrucken, was nach einiger Einstellarbeit (bei den CDs) dann auch funktioniert hat. Da meine CDs einen anderen Innendurchmesser haben (nämlich 2,3 cm) als wie meine DVDs (nämlich 2,00 bis 2,1 cm) wollte ich mir dazu ein neues Papierformat, genannt DVD Verbatim für die DVDs erstellen, was durch "duplizieren" und Einstellen der geänderten Parameter auch gelang.
Nun wollte ich wieder mit diesem Papierformat aus The Gimp drucken.
Zuallererst fiel mir auf, dass eine Fehlermeldung kam, dass der Drucker-Daemon nicht gestartet sei und damit u. a. auch der Tintenfüllstand nicht feststellbar sei (obwohl der Haken in den Einstellungen gesetzt ist).
Dieses Problem habe ich dann relativ schnell als root mit dem Befehl:

Code: Alles auswählen

 /etc/init.d/tpdaemon start 
lösen können.
Ich habe aber nun ein zweites, schwerwiegenderes Problem: als ich nun das neue Papierformat beim Druck aus Gimp (Menü: "Turboprint", nicht "Drucken") auswählen wollte, ging das zunächst noch, plötzlich war aber bei den Druckereinstellungen im Untermenü: Druck-Konfig nicht mehr "TurboPrint-Config..." zu sehen sondern nur noch "Gutenprint-Konfiguration...", dementsprechend verschwand auch mein ursprünglicher Eintrag "Canon_PIXMA_iP4200 Turboprint" im Untermenü "Druckermodel", stattdessen habe ich nur noch "Postscript Level 2" stehen, obwohl ich als Druckername immer noch "iP4200-TurboPrint" stehen habe... :roll:
Dementsprechend habe ich auch keine Bildvorschau mehr im linken Fenster sondern nur noch zwei nebeneinanderliegende Dreiecke, die in einem großen Dreick an der Spitze ein kleines blaues Viereck aufweisen.

Wie kann es sein, dass ich jetzt nur noch den freien Gutenprint-Treiber zur Auswahl habe? Hängt dies etwa mit eingeschränkten Lizenzrechten zusammen, dass ich mit der kostenlosen 30-Tage-Version mir kein neues Papierformat erstellen kann oder hat es mir einfach nur in einer Konfig-Datei, warum auch immer, eine Einstellung zerschossen?

Vielen Dank für die Antwort.

Andreas

tux666
Beiträge: 2
Registriert: Sa 22 Aug, 2015 07:41

Re: Druck-Konfig, Daemon funktionieren nicht mehr

Beitrag von tux666 » Di 25 Aug, 2015 09:00

Keine Idee, ob das irgendwie mit der Lizenz zusammenhängen könnte? Ich dachte die 30-Tage-Trial wäre innerhalb des Testzeitraumes ohne Einschränkung?
Eigentlich will ich es nach Windows-Manier vermeiden, die Installation sofort "plattzumachen" und gleich wieder neu zu installieren, da ich es von Linux-Seite gewohnt bin, der Sache erst auf den Grund zu gehen... :|

Andreas

zedonet
Administrator
Beiträge: 1473
Registriert: Fr 29 Sep, 2006 13:10

Re: Druck-Konfig, Daemon funktionieren nicht mehr

Beitrag von zedonet » Di 25 Aug, 2015 09:26

Hallo tux666,

mit der Testversion sollte das nichts zu tun haben, bzgl. des Gimp Plugins sind hier keine Einschränkungen vorgesehen. Erstmal scheint es sich bei Ihrem Problem ja nur auf das Drucken aus Gimp zu beziehen, oder? D.h. in anderen Anwendungen (z.B. OpenOffice) kann der TurboPrint Treiber ganz normal gewählt werden?
Das Gimp Plugin (für den "TurboPrint..." Druckdialog) wird bei der Installation von TurboPrint eingerichtet, wenn Gimp bereits auf dem Rechner installiert ist. Falls Gimp nachträglich neu installiert wird oder evtl. auch bei einem Update kann das Plugin möglicherweise gelöscht werden. Sie könnten sicherheitshalber einfach nochmals die Installation von TurboPrint starten, bereits eingerichtete Drucker werden dabei beibehalten.

Antworten