Installation 1.96-4 unter SuSE 10.3

Fragen zur Installation
Antworten
oktobaer
Beiträge: 2
Registriert: Di 25 Mär, 2008 00:15

Installation 1.96-4 unter SuSE 10.3

Beitrag von oktobaer » Di 25 Mär, 2008 00:28

Hallo!

Bei Installation als root:

# rpm --install turboprint-1.96-4.i386.rpm
error: Failed dependencies:
libgdk-1.2.so.0 is needed by turboprint-1.96-4.i386
libglib-1.2.so.0 is needed by turboprint-1.96-4.i386
libgmodule-1.2.so.0 is needed by turboprint-1.96-4.i386
libgtk-1.2.so.0 is needed by turboprint-1.96-4.i386

bekommen.

Kann diese lib's aber mit YASt nicht zum Nachinstallieren finden. Liegt das am neuen Kernel-Update 2.6.22.17-0.1

Bin nun ratlos! Was tun :?:

Oktogrüsse!

zedonet
Administrator
Beiträge: 1511
Registriert: Fr 29 Sep, 2006 13:10

Beitrag von zedonet » Di 25 Mär, 2008 11:31

Hallo,

das passende Yast-Paket heißt einfach "gtk" (alte gtk-Version 1.2 samt libgdk, ligblib, libgmodule) - dieses Paket einfach noch in Yast nachinstallieren.

oktobaer
Beiträge: 2
Registriert: Di 25 Mär, 2008 00:15

Beitrag von oktobaer » Di 25 Mär, 2008 22:48

... stimmt :P : Es war nurGTK2 installiert und das GTK1 musste ich unter Yast nachinstallieren; dann:


# rpm --install turboprint-1.96-4.i386.rpm
Restarting CUPS printing system...

chown: `lost+found': invalid user


UND ES FUNKTIONIERT!

Oktogrüße und Danke!

PS.: Gibt die letzte Meldung Grund zur Sorge?
---
Zusatzinfo aus YAST: gtk - A Library for the Creation of Graphical User Interfaces

This fast and versatile library was used all over the world for all GNOME applications, the GIMP, and several others. Originally it was written for the GIMP and hence has the name GIMP ToolKit. Many people like it because it is small, efficient, and very configurable.
Most applications which used GTK1 have since switched to GTK2. Besides a more flexible API, it provides improved text rendering using Pango and many other goodies, but GTK+ 2 lacks compatibility with GTK1, so to switch, programmers have to port applications to it.

zedonet
Administrator
Beiträge: 1511
Registriert: Fr 29 Sep, 2006 13:10

Beitrag von zedonet » Mi 26 Mär, 2008 11:20

...nein, ist nur ein Schönheitsfehler

Antworten