Schlechte Fotodruckqualität (Streifen)

Tipps und Tricks
Antworten
mRiesbeck
Beiträge: 20
Registriert: Mo 09 Feb, 2009 23:29

Schlechte Fotodruckqualität (Streifen)

Beitrag von mRiesbeck »

Hallo erstmal,

habe Ubuntu 8.10 + Turboprint 2.07 und einen Canon IP5000.

Ich drucke Fotos auf Glossy-Fotopapier mit 1.200 dpi... aber es
sind leichte Streifen auf dem Druck zu sehen. Das habe ich bisher
nicht optimiert bekommen. Egal welches Papier ich einstelle.

Bei 2.400 dpi sind die Streifen zwar weg, aber insgesamt kein so
brillianter Farbverlauf/Auflösung wie unter Windows.
Farbübergänge sind recht "krisselig".
Ausserdem dauert der Druck dann unangemessen lange.

Unter Windows ist der Druck auch bei 300dpi (10x15) perfekt.
300dpi sind mit Turboprint grottenschlecht für Fotodruck.

Gibt es irgendeine Einstellung, die das verursacht ?

Oder sind die Treiber nunmal nicht von so guter Qualität wie
die Original-Windowstreiber ? Wäre ja echt schade.

Textdruck ist ok. Aber dafür reicht ja auch der Standardtreiber unter
Ubuntu...


Gruss.... Mike
muck
Beiträge: 65
Registriert: So 02 Mär, 2008 15:47

Re: Schlechte Fotodruckqualität (Streifen)

Beitrag von muck »

mRiesbeck hat geschrieben: Ich drucke Fotos auf Glossy-Fotopapier mit 1.200 dpi... aber es
sind leichte Streifen auf dem Druck zu sehen. Das habe ich bisher
nicht optimiert bekommen. Egal welches Papier ich einstelle.
Ich würde zuerst mal eine Druckkopfjustage durchführen.

Gruss
muck
zedonet
Administrator
Beiträge: 1586
Registriert: Fr 29 Sep, 2006 13:10

Beitrag von zedonet »

Hallo,

die Druckqualität mit TurboPrint sollte gleich gut (oder besser) wie unter Windows sein (vorausgesetzt, es wird in der gleichen Qualitätsstufe gedruckt).

Wichtig ist, dass die richtige Papiersorte und eine genügend hohe Druckqualität gewählt wird.

Die Treiber-Grundeinstellungen werden im TurboPrint-Kontrollzentrum vorgenommen, viele Anwendungsprogramme bieten die Einstellungen auch im Druckdialog an - dort bitte vor dem Druck nochmals kontrollieren.

Falls der Ausdruck streifig ist, bitte über die "Toolbox" im TurboPrint-Kontrollzentrum einen Düsentestdruck machen und gegebenenfalls eine Düsenreinigung vornehmen.
mRiesbeck
Beiträge: 20
Registriert: Mo 09 Feb, 2009 23:29

Schon gemacht

Beitrag von mRiesbeck »

Hallo und danke für die schnelle Antwort,

den Düsentestdruck hatte ich ja schon gemacht. Alles OK.
Ebenso die Justierung. Eine auflösung von 1.200dpi ist ja nicht
gerade wenig. Trotzdem das Problem.

Unter Windows ist's wie gesagt auch bei 300dpi sauber.

Die Druckeinstellungen habe ich natürlich auch direkt vor dem
Druck auch in der Anwendung nochmal überprüft.

Egal ob Photoshop über Wine, Gimp oder sonstein Prog.
Leider habe ich diese Streifen... bzw. wenn 2.400dpi...
... dann keine Streifen aber dafür sind Farbübergänge nicht
klar... sondern wie gesagt "krisselig". Sieht man natürlich nicht aus 1m Entfernung. Aber aus der Nähe.

Was gibt's denn sonst noch für Möglichkeiten ?

Die Farben sind zumindest OK ;-)
zedonet
Administrator
Beiträge: 1586
Registriert: Fr 29 Sep, 2006 13:10

Beitrag von zedonet »

Posten Sie bitte einmal die Logdatei /var/log/turboprint/print.log, damit ich sehen kann, in welchem Papier- und Qualitätsmodus der Drucker läuft (Abschnitt für den letzten Ausdruck reicht).
mRiesbeck
Beiträge: 20
Registriert: Mo 09 Feb, 2009 23:29

Beitrag von mRiesbeck »

So, heute habe ich nochmal ein Testbild aus nem aktuellen Fotoshooting gedruckt.

Umgebung:
Ubuntu 9.04, Turboprint 2.10, 3GHz Core2 Duo, 4GB Ram, Gedruckt aus Eye Of Gnome

Habe mit Turboprint einen iP5000_Foto angelegt. A4, 1.200dpi, Canon PhotoPlusGlossy PP101 (Benutze aber von Staples das Photo Basic Glossy)

Das Originalbild hat eine Grösse von 2912x4368 Pixel. In Eye Of Gnome habe ich eine Druckgrösse von 18x12cm angegeben.

Bis der Auftrag gespoolt war dauerte ganze 5 1/2 MINUTEN !
Unerträglich lange. d. h. unbrauchbar.

Stelle ich weniger als 1.200 dpi ein (z. B. 600) geht's zwar ETWAS schneller, der Fotodruck ist dann aber grottenschlecht. Also auch wieder unbrauchbar.

Wie gesagt, unter Windows wird ruckzuck gespoolt und die Quali bei gleicher Bedingung ist schon bei 300dpi Druckqualität sehr gut.

1. Woran liegt es, dass das Spoolen so lange braucht.
2. Gibt es irgendeine Einstellung, die auch einen Druck mit
600 oder 300dpi für 18x12 Bilder in guter Qualität möglich macht ?

Hier ist mal der Auszug aus der print.log. Wäre echt klasse, wenn Du daraus was erkennen kannst, was mich weiterbringt. Ansonsten kann ich selbst Turboprint leider keinem Canon IP5000 Besitzer empfehlen.
Wobei das Programm ansonsten ja klasse ist/wäre.

Gruss Mike
#######################################################
NEW PRINT JOB Mi 27. Mai 00:22:37 CEST 2009 (pstoturboprint 2.06-2)
job-id 3
user vinzenz
title IMG_5293_Hot.jpg
copies 1
options Resolution=600x600dpi_1 zedoGreyToneA=0 zedoGreyToneB=0 zedoTAC=0 zedoInklimitC=0 zedoBrightness=0 MediaType=CanonPhotoPlusGlossyPP101_4 zedoCMYKspace=0 zedoColorC=0 zedoInklimitK=0 zedoMirror=0 zedoInklimitM=0 PageSize=A4 zedoColorK=0 zedoColorM=0 zedoUCR=0 zedoContrast=0 number-up=1 zedoDuplexadvanced=auto zedoBrightC=0 zedoColorY=0 zedoIntensity=0 zedoBorderlessExpand=2 zedoDithering=ErrorDiffusion zedoColorModel=RGB zedoDuplexAdjust=0 Duplex=None zedoRefLight=65 zedoGamut=0 InputSlot=ButtonSelect zedoBrightM=0 zedoColorspace=0 zedoIntent=perception_0 zedoInklimitY=0 job-uuid=urn:uuid:31d09087-9e75-3f63-6052-528e978f49cf
file
queue iP5000_Foto
test directory access:
drwxr-xr-x 2 vinzenz vinzenz 20480 2009-05-24 14:32 /usr/share/turboprint/printers
linux-gate.so.1 => (0xb80b1000)
libm.so.6 => /lib/tls/i686/cmov/libm.so.6 (0xb8079000)
libc.so.6 => /lib/tls/i686/cmov/libc.so.6 (0xb7f16000)
/lib/ld-linux.so.2 (0xb80b2000)
/usr/bin/tpprint -v2 -l/var/log/turboprint/print.log --ppdfile=/etc/cups/ppd/iP5000_Foto.ppd --psfeatures /tmp/pstoturboprint15605.chunk /tmp/pstoturboprint15605.var
Searching PPD file and postscript header for options...
check_flag_file: opening /var/turboprint/vinzenz/prv/iP5000_Foto
check_flag_file: opening /var/turboprint/vinzenz/sml/iP5000_Foto
----------- Start of var file -----------
ZEDOPARM="$ZEDOPARM zedoPageRegion=A4"
ZEDOPARM="$ZEDOPARM zedoMediaType=CanonPhotoPlusGlossyPP101_4"
ZEDOPARM="$ZEDOPARM zedoInputSlot=ButtonSelect"
ZEDOPARM="$ZEDOPARM zedoColorModel=RGB"
ZEDOPARM="$ZEDOPARM zedoDithering=ErrorDiffusion"
ZEDOPARM="$ZEDOPARM zedoMirror=0"
ZEDOPARM="$ZEDOPARM zedoDuplexAdjust=0"
ZEDOPARM="$ZEDOPARM zedoColorspace=0"
ZEDOPARM="$ZEDOPARM zedoCMYKspace=0"
ZEDOPARM="$ZEDOPARM zedoIntent=perception_0"
ZEDOPARM="$ZEDOPARM zedoIntensity=0"
ZEDOPARM="$ZEDOPARM zedoBrightness=0"
ZEDOPARM="$ZEDOPARM zedoContrast=0"
ZEDOPARM="$ZEDOPARM zedoColorY=0"
ZEDOPARM="$ZEDOPARM zedoColorM=0"
ZEDOPARM="$ZEDOPARM zedoColorC=0"
ZEDOPARM="$ZEDOPARM zedoColorK=0"
ZEDOPARM="$ZEDOPARM zedoInklimitY=0"
ZEDOPARM="$ZEDOPARM zedoInklimitM=0"
ZEDOPARM="$ZEDOPARM zedoInklimitC=0"
ZEDOPARM="$ZEDOPARM zedoInklimitK=0"
ZEDOPARM="$ZEDOPARM zedoRefLight=65"
ZEDOPARM="$ZEDOPARM zedoGreyToneA=0"
ZEDOPARM="$ZEDOPARM zedoGreyToneB=0"
ZEDOPARM="$ZEDOPARM zedoGamut=0"
ZEDOPARM="$ZEDOPARM zedoUCR=0"
ZEDOPARM="$ZEDOPARM zedoTAC=0"
ZEDOPARM="$ZEDOPARM zedoBrightC=0"
ZEDOPARM="$ZEDOPARM zedoBrightM=0"
ZEDOPARM="$ZEDOPARM zedoDuplexadvanced=auto"
ZEDOPARM="$ZEDOPARM zedoBorderlessExpand=2"
ZEDOPARM="$ZEDOPARM zedoResolution=600x600dpi_1"
ZEDOPARM="$ZEDOPARM zedoDuplex=None"
ZEDOPARM="$ZEDOPARM zedoPrinterDriver=Canon_PIXMA_iP5000"
GSPPDFOUND=1
GSCOLORMODE=2
GSXDPI=600
GSYDPI=600
GSWIDTH=4960
GSHEIGHT=7015
TPWIDTH=8268
TPHEIGHT=11693
TPXOFFSET=0
TPYOFFSET=0
DUPLEX=0
PREVIEW=0
NOPRINT=0
BORDERLESS=0
PVXDPI=87
PVYDPI=87
PVWIDTH=719
PVHEIGHT=1017
----------- End of var file -----------
tpstdin --parsedsc result=0
GSRESULT=GPL Ghostscript 8.64 (2009-02-03) GSVERSION=GPL GSMAJOR=8 GSMINOR=64 GSCUPSDEVICE=1
GSCOMMANDLINE=gs -sDEVICE=cups -r600x600 -dNOMEDIAATTRS -dSAFER -dNOPAUSE -dBATCH
TPCOMMANDLINE=/usr/bin/tpprint --cups -v2 -l/var/log/turboprint/print.log --ppdfile=/etc/cups/ppd/iP5000_Foto.ppd --psheader=/etc/cups/ppd/iP5000_Foto.ppd ---zedoPageRegion=A4 ---zedoMediaType=CanonPhotoPlusGlossyPP101_4 ---zedoInputSlot=ButtonSelect ---zedoColorModel=RGB ---zedoDithering=ErrorDiffusion ---zedoMirror=0 ---zedoDuplexAdjust=0 ---zedoColorspace=0 ---zedoCMYKspace=0 ---zedoIntent=perception_0 ---zedoIntensity=0 ---zedoBrightness=0 ---zedoContrast=0 ---zedoColorY=0 ---zedoColorM=0 ---zedoColorC=0 ---zedoColorK=0 ---zedoInklimitY=0 ---zedoInklimitM=0 ---zedoInklimitC=0 ---zedoInklimitK=0 ---zedoRefLight=65 ---zedoGreyToneA=0 ---zedoGreyToneB=0 ---zedoGamut=0 ---zedoUCR=0 ---zedoTAC=0 ---zedoBrightC=0 ---zedoBrightM=0 ---zedoDuplexadvanced=auto ---zedoBorderlessExpand=2 ---zedoResolution=600x600dpi_1 ---zedoDuplex=None ---zedoPrinterDriver=Canon_PIXMA_iP5000 --jobid=3 --username=vinzenz '--title=IMG_5293_Hot.jpg'
COMPLETEPIPE=/usr/share/turboprint/lib/tpstdin --paste /tmp/pstoturboprint15605.chunk | gs -sDEVICE=cups -r600x600 -dNOMEDIAATTRS -dSAFER -dNOPAUSE -dBATCH -sOutputFile=/tmp/pstoturboprint15605.fifo - >> /var/log/turboprint/print.log
PREVIEWPIPE=
----------- Start of print job -----------
starting child process
tpprint 2.10-1 (04-MAY-2009) - TurboPrint printer driver
Copyright (C)ZEDOnet GmbH, Irsee, Germany. All rights reserved.
Could not get a free pipe
Searching PPD file and postscript header for options...
GPL Ghostscript 8.64 (2009-02-03)
Copyright (C) 2009 Artifex Software, Inc. All rights reserved.
This software comes with NO WARRANTY: see the file PUBLIC for details.
interpret_ps: no output file specified
::set_info_paths: setting preview file to /var/turboprint/vinzenz/zmf/3.zmf
Filetype=CupsRasterbits_per_pixel=32 bytes_per_line=19200 width=4800 height=6825
RGB Mode
Printer=Canon_PIXMA_iP5000; Module=Canon; Id=i865
Colormode=2; Cartridge=0=Color; Quality=1=Medium; Paper=3=Canon PhotoPlusGlossy PP101
Pagesize=4=A4; Paper Input=0=Button Select; Paper Output=0=Front
Duplex=0=Off; Copies=1; Mirror=0; Dithering=0; Flip=0
Page x=4800 y=6825; AppDpi x=600 y=600; DitDpi x=600 y=600;
PrnDpi x=600 y=600; Overlay=0

tpfile::get_patchsample_table: paper=Canon Photo Paper Plus Glossy PP101
table::get_patchsample_struct: default_bright_ink set to default 100
patches; linmode=density
table::build_gamma_table: i=0 color=4 gamma=100 max=100 saturation=100
gamma 100 max 100 saturation 100 for channel 0
correction=32767
table::build_gamma_table: i=1 color=5 gamma=100 max=100 saturation=100
gamma 100 max 100 saturation 100 for channel 1
correction=33047
table::build_gamma_table: i=2 color=6 gamma=100 max=100 saturation=100
gamma 100 max 100 saturation 100 for channel 2
correction=32885
table::build_gamma_table: i=3 color=7 gamma=100 max=100 saturation=100
gamma 100 max 100 saturation 100 for channel 3
correction=32258
grey: a=0 b=0; colorspace=APPLE; cmykspace=0; intent=perceptual; daylight = 6500K
multi_profile_switch=150 multi_c2_switch=100 multi_m2_switch=100
ucr_up=166; max_ink=765; ucr_add=128
bright_cyan_fac=0 bright_magenta_fac=0
black_fac=100 cyan_fac=54 magenta_fac=60 yellow_fac=38
printer white:l=958 a-005 b-022
printer white poly:l=958 a-005 b-022
printer black:l=081 a+011 b-071
printer black poly:l=090 a-009 b-013
printer darkest poly:l=090 a-009 b-013
black l=00 a+00 b+00 => l=090 a-009 b-013: K99 C41 M44 Y39 c00 m00 k00 g00
black94 l=06 a+00 b+00 => l=168 a-003 b-029: K41 C55 M67 Y63 c00 m00 k00 g00
black87 l=17 a+00 b+00 => l=237 a+003 b-024: K09 C53 M67 Y64 c00 m00 k00 g00
black75 l=34 a+00 b+00 => l=380 a+000 b-028: K00 C40 M45 Y43 c00 m00 k00 g00
black62 l=48 a+00 b+00 => l=501 a+000 b-031: K00 C28 M30 Y29 c00 m00 k00 g00
black50 l=60 a+00 b+00 => l=607 a-002 b-033: K00 C20 M20 Y19 c00 m00 k00 g00
black37 l=71 a+00 b+00 => l=703 a-003 b-035: K00 C14 M12 Y12 c00 m00 k00 g00
black25 l=82 a+00 b+00 => l=793 a-003 b-037: K00 C08 M07 Y07 c00 m00 k00 g00
black12 l=91 a+00 b+00 => l=877 a-004 b-039: K00 C03 M03 Y02 c00 m00 k00 g00
white l=99 a+00 b+00 => l=957 a-007 b-023: K00 C00 M00 Y00 c00 m00 k00 g00
cyan l=89 a-54 b-17 => l=786 a-244 b-271: K00 C24 M00 Y00 c00 m00 k00 g00
magenta l=64 a+87 b-52 => l=621 a+671 b-223: K00 C00 M53 Y00 c00 m00 k00 g00
yellow l=97 a-14 b+86 => l=912 a-134 b+727: K00 C00 M00 Y55 c00 m00 k00 g00
red l=58 a+77 b+70 => l=545 a+604 b+532: K00 C00 M70 Y75 c00 m00 k00 g00
green l=86 a-84 b+72 => l=745 a-495 b+514: K00 C21 M00 Y60 c00 m00 k00 g00
blue l=32 a+60 b-105 => l=345 a+275 b-639: K00 C68 M44 Y00 c00 m00 k00 g00
canon::setup_printer_info: number of channels: 4
canon_info.model_level=3
canon::setup_printer_info: bits per pixel: 4
canon::setup_printer_info: S600/800 mode
canon::setup_printer_info: s600 split colors
canon::setup_printer_info: i865 photo black used
Canon init string: esc(c 30 9 2 esc(J 1
esc(t 80 80 1 esc(l 33 d
esc(p 2ab 0 1e0 0

Colormatch file=BCI3e6; Curves=2400dpi_ip5000; Table=canon_pp101
Report at end of pdrive_class::begin_page
Total memory usage=2725545
PREVIEW y_offset=70 org_height=7016 src_scanline=70 preview_scanline=6
cups left=0 top=0 width=4800 height=6825 (pixels)
calculate_dim: print left=0 top=0 width=4800 height=6825
calculate_dim: section left=0 top=0 width=4800 height=6825
Print size in printer pixels, relative to printable area:
left=0 top=0 width=4800 height=6825
Time for <Profile> = 340
Time for <Color> = 1580
Time for <Dither> = 1120
Time for <Print> = 180
Time for <Total> = 3010
Line counters: skip=0; bitmap=0; others=6825; 8bit=0; white=2573; b/w=0
Color 0 sum: 2
Color 1 sum: 9
Color 2 sum: 15
Color 3 sum: 35
total sum: 61
pixmap_class::open: can't read magic header
print_page: end of input file
Report at end of pdrivecontrol_class::release_printer
Total memory usage=0
child process terminated
------------ End of print job - result = 0 ------------
job cancelling procedure - TPPID=15639 GSPID=15641 PVPID=
------------ END of tpprint filter ------------
zedonet
Administrator
Beiträge: 1586
Registriert: Fr 29 Sep, 2006 13:10

Beitrag von zedonet »

Hallo,

wir haben hier Testdrucke gemacht, siehe auch Ihr anderer Thread

http://www.turboprint.de/support/viewto ... =1596#1596

Die Zeiten bis zum Druckstart unter Ubuntu 9.04 sind nicht optimal - hier gibt es offensichtlich eine Verzögerung durch eine Wandlung der Druckdaten von Postscript nach PDF und zurück durch das CUPS-Drucksystem. Wir prüfen noch, ob un wie dies beschleunigt werden kann.

Die Wartezeit auf einem vergleichbaren Rechner lagen jedoch bei uns deutlich niedriger (weniger als die halbe Zeit bis zum Druckstart), deshalb sollten wir prüfen, ob noch irgendwo ein Installationsproblem vorliegt.

Könnten Sie bitte einmal vor dem Druck den TurboPrint-Monitor öffnen und folgende Zeiten stoppen (das Häkchen bei "Druckvorschau" bitte abschalten):

1. wie lange braucht es vom Druckbefehl im Anwendungsprogramm bis der Druckjob im TurboPrint Monitor angeziegt wird (Anzeige "1 Job", Meldung "Processing Job")

2. bald darauf ändert sich die Anzeige im Spooler, ein Feld mit den Einstellungen für den aktuellen Druckauftrag wird eingeblendet. Wie lange dauert es (ab "1.")?

3. der erste Teil des Seiten-Thumbnails wird sichtbar. Bitte auch hier die Zeit (ab "2.") notieren

Zusätzlich bitte noch die System-Logdatei /var/log/cups/error_log nach dem Ausdruck an uns mailen: mail (at) zedonet (punkt) de
mRiesbeck
Beiträge: 20
Registriert: Mo 09 Feb, 2009 23:29

Beitrag von mRiesbeck »

Habe jetzt nochmal die Zeiten gestoppt.

GIMP: Turboprint-Druck

Nach
07 Sek. wird der Auftrag im Turboprintmonitor angezeigt
18 Sek. steht dort "Es wird gedruckt"
39 Sek. steht dort "Processing 1 Page"
45 Sek. stehen dort die Druckeinstellungen und der Druck beginnt.

GIMP: Gimp-Druck

08 Sek. wird der Auftrag im Turboprintmonitor angezeigt
13 Sek. steht dort "Es wird gedruckt"
14 Sek. steht dort "Processing 1 Page" (
4 Min. 55 Sek. stehen dort die Druckeinstellungen und der Druck beginnt.

Aus Eye Of Gnome EOF

08 Sek. wird der Auftrag im Turboprintmonitor angezeigt
10 Sek. steht dort "Es wird gedruckt"
12 Sek. steht dort "Processing 1 Page" (
5 Min. 05 Sek. stehen dort die Druckeinstellungen und der Druck beginnt.

In der error_log steht nichts drin.
Hab die Datei auch mal gelöscht, wurde aber nicht neu erzeugt.

ABER: Es kann doch nicht sein, dass der Druck nur mit dem Gimp-Turboprintmodul einigermassen ersträglich schnell beginnt.
(Unter Intrepid waren die Zeiten auch so lang.)

Das sollte doch auch funktionieren, wenn ich aus irgendeiner anderen Anwendung (EOF, Digikam, F-Spot etc.) einen Druck auf den mit Turboprint angelegten iP5000_Foto (1.200dpi) anstosse.


Zudem habe ich noch das Problem, dass der Fotodruck nicht wirklich gut ist. (Kleine feine Streifen (1.200dpi)). Liegt aber nicht am Drucker, da der Druck unter Windows 1a sauber ist. Können Sie dazu was in der bereits geposteten Datei erkennen ?

Danke schonmal für die Hilfe. Hoffe ja, da kommt noch was Brauchbares.

Für Jaunty liegt bei den (VORAB veröffentlichten) Updates auch was mit CUPS drin. Habe das aber nicht installiert, weil es noch nicht freigegeben ist.

Gruss Mike
mRiesbeck
Beiträge: 20
Registriert: Mo 09 Feb, 2009 23:29

Und ?

Beitrag von mRiesbeck »

Gibt's schon neue Erkenntnisse ? :-)
zedonet
Administrator
Beiträge: 1586
Registriert: Fr 29 Sep, 2006 13:10

Beitrag von zedonet »

Hallo,

es hat leider etwas gedauert, aber es gibt jetzt unter

ftp://ftp.zedonet.de/tp2

eine Release-Candidate-Version von turboprint-2.11-1, die das Problem mit der langen Wartezeit vor dem Druckstart behebt (zumindest bei unseren Tests).

Falls Sie diese Version herunterladen und installieren, wäre ich für eine Rückmeldung dankbar.
mRiesbeck
Beiträge: 20
Registriert: Mo 09 Feb, 2009 23:29

Druckqualität wieder OK

Beitrag von mRiesbeck »

Hallo,

auch hier nochmal ein kurzes Feedback.
Die Qualität mit Version 2.11 ist wieder OK.

Zwar nicht ganz so gut wie mit dem Originaltreiber
unter Windows... aber völlig akzeptabel.
Die Streifen sind jedenfalls weg.

Danke !
Antworten