tintenstand bei treiber 1.95_1

Fragen zur Installation
Antworten
jürgen
Beiträge: 5
Registriert: Fr 29 Dez, 2006 12:03

tintenstand bei treiber 1.95_1

Beitrag von jürgen » Fr 29 Dez, 2006 12:09

hi, nach der installation des neuen treibers 1.95 auf ubuntu dapper geht die tintenstandsanzeige nicht mehr.

# Printer configuration file for CUPS v1.2.2
# Written by cupsd on 2006-12-29 11:35
<DefaultPrinter tp0>
Info Canon_i865
Location
DeviceURI usb://Canon/i865
State Idle
StateTime 1167388479
Accepting Yes
Shared Yes
JobSheets none none
QuotaPeriod 0
PageLimit 0
KLimit 0
OpPolicy default
ErrorPolicy stop-printer
</Printer>

gibts da ne lösung?
grüße, jürgen

zedonet
Administrator
Beiträge: 1480
Registriert: Fr 29 Sep, 2006 13:10

Beitrag von zedonet » Do 04 Jan, 2007 17:59

Welche TurboPrint-Version hatten Sie bisher - 1.94-4 oder eine ältere?

jürgen
Beiträge: 5
Registriert: Fr 29 Dez, 2006 12:03

Beitrag von jürgen » Do 04 Jan, 2007 23:08

hallo, bisher hatte ich die 1.94-4
einen schönen tag noch, ciao jürgen

Machtnix
Beiträge: 11
Registriert: Mi 10 Jan, 2007 11:32

Beitrag von Machtnix » Fr 12 Jan, 2007 13:23

Hallo,

es sollte gehen, entweder die Berechtigungen für den USB-Anschluss umzusetzen, siehe hier oder den User, mit dem gearbeitet wird, in diejenige Gruppe aufzunehmen, die Schreibrechte auf diesen Port hat, also:

ls -l /dev/usb/lp0 bzw.
ls -l /dev/usblp0 (ich weiß nicht, welche Version Ubuntu verwendet)

Dann die Gruppe ansehen, die hoffentlich Schreibrechte hat - bei mir unter Arch Linux ist es "lp", und den User, der drucken soll, in diese Gruppe aufnehmen:
sudo usermod -a -G <Gruppe> <Benutzername>

Nach einem Logout / Logout, damit die Gruppenänderung wirksam wird, sollte das mit dem Tintenstand gehen.

jürgen
Beiträge: 5
Registriert: Fr 29 Dez, 2006 12:03

Beitrag von jürgen » Mo 15 Jan, 2007 10:27

hi machtnix, hatte schon nicht mehr damit gerechnet, dass jemand antwortet. danke.
leider funktioniert die lösung nicht.

"ls -l /dev/usb/lp0 bzw.
ls -l /dev/usblp0 (ich weiß nicht, welche Version Ubuntu verwendet)"

beide varianten melden "no such file or directory.

mittlerweile verwende ich ubuntu 6.10 (edgy eft)
vielleicht weiss ja noch jemand eine lösung?
vielen dank jürgen

Machtnix
Beiträge: 11
Registriert: Mi 10 Jan, 2007 11:32

Beitrag von Machtnix » Mo 15 Jan, 2007 23:33

Ich habe hier nur die xubuntu-Testvervions 7.04...
sie sollte sich aber in diesem Punkt nicht von Edgy Eft unterscheiden.

dieter@xubuntu:~$ ls -l /dev/usb<TAB>
usbdev1.1_ep00 usbdev3.1_ep00 usbdev3.2_ep82 usblp0
usbdev1.1_ep81 usbdev3.1_ep81 usbdev3.3_ep00
usbdev2.1_ep00 usbdev3.2_ep00 usbdev3.3_ep02
usbdev2.1_ep81 usbdev3.2_ep01 usbdev3.3_ep81
dieter@xubuntu:~$ ls -l /dev/usblp0
crw-rw---- 1 root lp 180, 0 2007-01-16 00:21 /dev/usblp0
dieter@xubuntu:~$

Es müsste also "/dev/usblp0" sein und die Gruppe ist auch hier "lp". Falls es schlecht zu erkennen ist: Es ist "usb"<kleines L>"p"<Null> in einem Wort.

cups läuft hoffentlich?

jürgen
Beiträge: 5
Registriert: Fr 29 Dez, 2006 12:03

Beitrag von jürgen » Di 16 Jan, 2007 10:14

hallo und schon mal danke!
nun, eine gruppe lp gibts bei mir nicht, dafür aber lpadmin und in dieser gruppe ist der benutzer eingetragen.
cups 1.2.4 läuft und findet auch meinen drucker, der ja auch druckt.
wenn ich das turboprint config tool als root starte, zeigt er mir aber auch keinen tintenstand an. daher vermute ich, das problem ist nicht bei den rechten zu suchen.
tja ich bin ratlos und ehrlicherweise finde ich, dass ein treiber für 30 € zumindest die features des gerätes auch unterstützen sollte.
vielen dank machtnix, und vielleicht hast du ja noch eine idee
ciao, jürgen

jürgen
Beiträge: 5
Registriert: Fr 29 Dez, 2006 12:03

Beitrag von jürgen » Mi 31 Jan, 2007 21:00

ahh, der frust hat ein ende!
die neue 1.95.2 version zeigt auch wieder den tintenstand an.
danke sehr, ciao jürgen

Antworten